Viewing 5 reply threads
  • Author
    Posts
    • #15445
      Erik M-H
      Participant

      I’ve been modifying the “waterlines” style mentioned in the really helpful “coasts” tutorial, to find something that’s a closer match to my map’s style.

       

      The tutorial discusses “combining” elements (with “append”) to get the waterlines to behave appropriately when you have both a shoreline and an island — and for the most part, this seems to work.

       

      I’ve found, though, that increasing the distance of the waterlines from the shore causes problems even when the elements are combined.

       

      To demonstrate, I’ve dramatically simplified my modified waterline style, such that it’s not very pretty or useable but does clearly show the problem.

       

      I’ve put two screenshots and an exported “waterline showing bug” style in a Dropbox folder here .

       

      Any suggestions for a workaround (other than “don’t do that”!) would be welcome — as would a fix, of course! :-)

       

    • #16229
      Mapdiva
      Moderator

      Hi Eric, From your screenshot before combining objects it looks possible that the center island might not be a “closed” path, thus leaving a small gap where the ends meet. Before combining the shapes, try selecting it and choose ‘Edit > Paths & Tracks > Close’ from the main menu.

      Assuming this is a closed path and you still see the effect, there are a couple style settings to tweak that should tidy things up. On the style you provided, try changing the stroke End Cap from the “Butt Cap” setting (squared-off ending to the stroke) to the “Round Cap” setting. When I applied this setting on the style you provided it cleaned up the line quality considerably. Though not necessary, you might also play with using the “Clipping > Outside/inside” setting with waterlines.

      Finally, you might see this effect also if the curve handles are twisted in the wrong direction at the end points of the stroke, thus causing the stroke style to invert on itself. You may have to zoom in quite close to see if this is the case. If they need adjusted, hold the CMND-key to move the curve handles independently. Let us know if that does it or not. Thanks.

    • #16230
      Erik M-H
      Participant

      Thanks so much for the great list of suggestions, Jill!

      Unfortunately, I have only bad news:

      it looks possible that the center island might not be a “closed” path

      I broke up the combined objects, reconverted to paths, and checked to see whether I was allowed to close anything (selecting each island and the continent individually in turn); everything was already closed.

      try changing the stroke End Cap from the “Butt Cap” setting … to the “Round Cap” setting

      I tried doing this with each of the component strokes in my style, and then with all of them together. It did result in a small improvement, but by no means solved the problem.

      you might see this effect also if the curve handles are twisted in the wrong direction at the end points of the stroke, thus causing the stroke style to invert on itself

      This makes good sense. I was pretty sure I hadn’t left any handles this way, but I zoomed in to 3200% (so that the small island takes up nearly my whole screen), and verified that there was no surprise inverted twisting. :-(

      I also tried clipping, per your suggestion. Clipping each stroke “inside” made it disappear; “outside” had no effect. When I hid the higher “land area” layer, I could see that the unwanted/unneeded waterlines that had been being hidden by the land masses were not generated when I clipped the strokes outside, so I retained that setting. But, again, it had no effect on the problem at hand.

      Grasping at straws, I also tried changing the solid strokes to dashed — which actually completely solved the problem, but made for some other unwanted effects, as you can probably imagine. (Actually, I may keep it this way for now, as I find these to be less of an annoyance than the artifacts were discussing here.)

      I found that adding a tiny offset (.009cm) to a few of the strokes solves the problem completely, without any unwanted side effects at all (well, it does change the distance between the affected stroke and the shoreline, but that’s fine).

      But: this causes Ortelius to slow to a complete crawl. The amount of the slowdown is inversely proportional to my zoom level (1600% zoom presents tolerable delays; 400% gives me frequent 12-second spinning pizzas). The number of strokes that include an offset is also relevant.

      Any further thoughts? I suppose I could just keep the coastline turned off while I work on other things, retain the offsets, and turn the coastline on only when I was completely finished and wanted to generate PDFs and/or exports. I’d rather have the pretty coastlines visible, though, the better to match their flavor and style….

      Many thanks for your continued help!

      — Erik

    • #16231
      Mapdiva
      Moderator

      Thanks for testing these out. Can you email me your file and we’ll do some more digging? – Jill

    • #16232
      Erik M-H
      Participant

      Will do; I’m paring it down to size now.

      Will the file itself include all used custom styles?

    • #16233
      Mapdiva
      Moderator

      Correct. Ortelius files always embed custom styles and symbols even if they aren’t loaded into a Library on the recipient’s machine. As a side note, when you open a file like this any non-library styles will show in the Library Manager under “Open Documents” library while that doc is open. You can also copy or move non-library styles from “Open Documents” library into any User Libraries. :)

Viewing 5 reply threads
  • The topic ‘Waterline bug?’ is closed to new replies.